const regex = /^(([1-9]|0[1-9]|1[0-2])\/([1-9]|0[1-9]|1\d|2\d|3[01])\/(19|20)\d{2}|[nN]\/[aA])$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(([1-9]|0[1-9]|1[0-2])\\\/([1-9]|0[1-9]|1\\d|2\\d|3[01])\\\/(19|20)\\d{2}|[nN]\\\/[aA])$', 'gm')
const str = `01/05/2015
1/5/2015
01/5/2015
1/05/2015
n/a
n/A
N/A
N/a
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}