import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(([1-9]|0[1-9]|1[0-2])\\/([1-9]|0[1-9]|1\\d|2\\d|3[01])\\/(19|20)\\d{2}|[nN]\\/[aA])$";
final String string = "01/05/2015\n"
+ "1/5/2015\n"
+ "01/5/2015\n"
+ "1/05/2015\n"
+ "n/a\n"
+ "n/A\n"
+ "N/A\n"
+ "N/a\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}