const regex = /^(0?[1-9]|1\d|2[0-8]|29(?=[-]\d?\d[-](?!1[01345789]00|2[1235679]00)\d\d(?:[02468][048]|[13579][26]))|30(?![-]0?2)|31(?=[-]0?[13578][-]|[-]1[02]))[-](0?[1-9]|1[0-2])[-]([12]\d{3})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(0?[1-9]|1\\d|2[0-8]|29(?=[-]\\d?\\d[-](?!1[01345789]00|2[1235679]00)\\d\\d(?:[02468][048]|[13579][26]))|30(?![-]0?2)|31(?=[-]0?[13578][-]|[-]1[02]))[-](0?[1-9]|1[0-2])[-]([12]\\d{3})$', 'gm')
const str = `31-1-2000
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}