import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(0?[1-9]|1\\d|2[0-8]|29(?=[-]\\d?\\d[-](?!1[01345789]00|2[1235679]00)\\d\\d(?:[02468][048]|[13579][26]))|30(?![-]0?2)|31(?=[-]0?[13578][-]|[-]1[02]))[-](0?[1-9]|1[0-2])[-]([12]\\d{3})$";
final String string = "31-1-2000\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}