const regex = /\s[0-9]\s([A-Z]{2,3})([0-9\s]{4})\s([A-Z])\s\s([A-Z]{1,2})\s([0-9]{1,2})(JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC)\s\s([A-Z]{3})([A-Z]{3})\s([A-Z0-9]{3})\s(X|\s)\s([0-9]{2})([0-9]{2})\s([0-9]{2})([0-9]{2})(\s|\*)([A-Z]*)\s(.*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s[0-9]\\s([A-Z]{2,3})([0-9\\s]{4})\\s([A-Z])\\s\\s([A-Z]{1,2})\\s([0-9]{1,2})(JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC)\\s\\s([A-Z]{3})([A-Z]{3})\\s([A-Z0-9]{3})\\s(X|\\s)\\s([0-9]{2})([0-9]{2})\\s([0-9]{2})([0-9]{2})(\\s|\\*)([A-Z]*)\\s(.*)', 'g')
const str = `1.3SAHIN/FATMAMRS/MUSTAFAMR/SEMIHMSTR 4.I/1SAHIN/MUSABMSTR
2ZSTKOS 13SEP UNBFML
1 TK1616 W WE 25NOV FRASAW HK3 X 1745 2145 Y M01.1E
2 TK7230 Y WE 25NOV SAWTZX HK3 2245 0025*Y M01.2E
ANADOLUJET IS A TRADEMARK OF TURKISH AIRLINES
3 TK2839 Y SA 12DEC TZXIST HK3 X 0645 0840 Y M02.1E
4 TK1591 S SA 12DEC ISTFRA HK3 1140 1355 Y M02.2E
FONE-2ZS00-T REISEBURO SAHIN 06042/951616`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}