import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s[0-9]\\s([A-Z]{2,3})([0-9\\s]{4})\\s([A-Z])\\s\\s([A-Z]{1,2})\\s([0-9]{1,2})(JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC)\\s\\s([A-Z]{3})([A-Z]{3})\\s([A-Z0-9]{3})\\s(X|\\s)\\s([0-9]{2})([0-9]{2})\\s([0-9]{2})([0-9]{2})(\\s|\\*)([A-Z]*)\\s(.*)";
final String string = "1.3SAHIN/FATMAMRS/MUSTAFAMR/SEMIHMSTR 4.I/1SAHIN/MUSABMSTR\n"
+ "2ZSTKOS 13SEP UNBFML\n"
+ " 1 TK1616 W WE 25NOV FRASAW HK3 X 1745 2145 Y M01.1E\n"
+ " 2 TK7230 Y WE 25NOV SAWTZX HK3 2245 0025*Y M01.2E\n"
+ " ANADOLUJET IS A TRADEMARK OF TURKISH AIRLINES\n"
+ " 3 TK2839 Y SA 12DEC TZXIST HK3 X 0645 0840 Y M02.1E\n"
+ " 4 TK1591 S SA 12DEC ISTFRA HK3 1140 1355 Y M02.2E\n"
+ "FONE-2ZS00-T REISEBURO SAHIN 06042/951616";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}