re = /^([_a-z0-9]+[\._a-z0-9]*)(\+[a-z0-9]+)?@(([a-z0-9-]+\.)*[a-z]{2,4})$/
str = 'a@a.co'
# Print the match result
str.match(re) do |match|
puts match.to_s
end