const regex = /^([_a-z0-9]+[\._a-z0-9]*)(\+[a-z0-9]+)?@(([a-z0-9-]+\.)*[a-z]{2,4})$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([_a-z0-9]+[\\._a-z0-9]*)(\\+[a-z0-9]+)?@(([a-z0-9-]+\\.)*[a-z]{2,4})$', '')
const str = `a@a.co`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}