$re = '/^[^\s]+(?=\s+\w{7}\s)/m';
$str = 'remotes/origin/main 47cdfee add GetLimits function to HelperFunction.ps1 (needed for Labranges)
remotes/origin/splitdvp 9499341 $cleanstring scriptblock removes all nonword chars that survive replace';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);