using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^\s]+(?=\s+\w{7}\s)";
string input = @"remotes/origin/main 47cdfee add GetLimits function to HelperFunction.ps1 (needed for Labranges)
remotes/origin/splitdvp 9499341 $cleanstring scriptblock removes all nonword chars that survive replace";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}