const regex = /(?'type'[\w|\[\]\/]+)\s*\$(?'name'\w+)\s*(=\s*(?'default'[\w\'\\"]+)|)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?\'type\'[\\w|\\[\\]\\\/]+)\\s*\\$(?\'name\'\\w+)\\s*(=\\s*(?\'default\'[\\w\\\'\\\\"]+)|)', 'gm')
const str = `string \$arg1='klk', \$arg2 = 222, boolean \$eee= false, \$arg4, \$arg5="fdsfds"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}