package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?'type'[\w|\[\]\/]+)\s*\$(?'name'\w+)\s*(=\s*(?'default'[\w\'\\"]+)|)`)
var str = `string $arg1='klk', $arg2 = 222, boolean $eee= false, $arg4, $arg5="fdsfds"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}