re = /^(https?:\/\/)?([\da-z\.-]+)\.([a-z\.]{2,6})([\/\w \.-]*)*\/?$/
str = 'http://www.mchinwe.byretetey3y34v/t34v/34v5/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end