package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(https?:\/\/)?([\da-z\.-]+)\.([a-z\.]{2,6})([\/\w \.-]*)*\/?$`)
var str = `http://www.mchinwe.byretetey3y34v/t34v/34v5/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}