$re = '/0[1-7][0-7]*/m';
$str = '00123
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);