package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)0[1-7][0-7]*`)
var str = `00123
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}