# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!\.)(\b[a-zA-Z_]+[a-zA-Z0-9_]+)\.[a-zA-Z0-9_\.]+"
test_str = ("module.func()\n"
"module.class.func()\n"
"module.module.class . func()\n"
"__module__.module.class.func()\n\n"
"module.constant\n"
"module.class.constant\n"
"module.class.class.constant\n\n"
"module11.func()\n"
"modu123le.class.func()\n"
"modu123le.module.class.func()\n"
"modu123le.module123.class.func()\n\n"
"\"1 if module11.func(col) == 'A' else 3\"\n"
"\"1 if module11.func(col) == 'A' else ( _module.constant == 'B') else 34\"\n\n"
"\"module.func()\"\n\n\n"
"1.0 \n"
"1module.func() \n"
"2module.class.func()\n"
"col.upper() ##No way to know whether col is a module \n\n"
"module . func() ##Need to remove spaces before and after .\n"
"module . class . func() \n\n\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.