package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)^\D{2,}\.(\D)\.\D{2}.*$`)
var str = `GO.C.O.3 - App - IQOS Connect Widget (production)
GO.C.X.1 - App - IQOS Connect (raw)
GO.C.X.2 - App - My IQOS App (raw)
GO.C.X.3 - App - IQOS Connect Widget (raw)
GO.W.O.1 - iqos.com (production)
GO.W.U.1 - iqos.com (user-id)
GO.W.X.1 - iqos.com (raw)
OBSOLETE - GO.W.X.2 - iqos.com (raw excl. params)
OBSOLETE - Test view
AL.A.O.1 - Consolidated (production)
AL.A.X.1 - Consolidated (raw)
AL.W.O.1 - al.iqos.com (production)
AL.W.U.1 - al.iqos.com (user-id)
AL.W.X.1 - al.iqos.com (raw)
ar.myiqos.com (raw)
AR.W.O.1 - iqos.com.ar (production)
AM.A.O.1 - Consolidated (production)
AM.A.X.1 - Consolidated (raw)
AM.W.O.1 - am.iqos.com (production)
AM.W.U.1 - am.iqos.com (user-id)
AM.W.X.1 - am.iqos.com​ (raw)
All Web Site Data
AT.A.O.1 - Consolidated (production)
AT.A.X.1 - Consolidated (raw)
AT.W.O.1 - at.iqos.com (production)
AT.W.U.1 - at.iqos.com (user-id)
AT.W.X.1 - at.iqos.com (raw)
AT.Z.O.1 - iqosinfo.at
AT.Z.O.2 - iqosjetzt.com
AT.Z.O.3 - iqosempfehlen.at
AT.Z.O.4 - iqostesten.at
AT.Z.O.5 - testeiqos.at
AT.Z.O.6 - iqosregistrieren.at
AT.Z.O.7 - iqosprobieren.at`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}