#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)^\D{2,}\.(\D)\.\D{2}.*$"
Local $sString = "GO.C.O.3 - App - IQOS Connect Widget (production)" & @CRLF & _
"GO.C.X.1 - App - IQOS Connect (raw)" & @CRLF & _
"GO.C.X.2 - App - My IQOS App (raw)" & @CRLF & _
"GO.C.X.3 - App - IQOS Connect Widget (raw)" & @CRLF & _
"GO.W.O.1 - iqos.com (production)" & @CRLF & _
"GO.W.U.1 - iqos.com (user-id)" & @CRLF & _
"GO.W.X.1 - iqos.com (raw)" & @CRLF & _
"OBSOLETE - GO.W.X.2 - iqos.com (raw excl. params)" & @CRLF & _
"OBSOLETE - Test view" & @CRLF & _
"AL.A.O.1 - Consolidated (production)" & @CRLF & _
"AL.A.X.1 - Consolidated (raw)" & @CRLF & _
"AL.W.O.1 - al.iqos.com (production)" & @CRLF & _
"AL.W.U.1 - al.iqos.com (user-id)" & @CRLF & _
"AL.W.X.1 - al.iqos.com (raw)" & @CRLF & _
"ar.myiqos.com (raw)" & @CRLF & _
"AR.W.O.1 - iqos.com.ar (production)" & @CRLF & _
"AM.A.O.1 - Consolidated (production)" & @CRLF & _
"AM.A.X.1 - Consolidated (raw)" & @CRLF & _
"AM.W.O.1 - am.iqos.com (production)" & @CRLF & _
"AM.W.U.1 - am.iqos.com (user-id)" & @CRLF & _
"AM.W.X.1 - am.iqos.com​ (raw)" & @CRLF & _
"All Web Site Data" & @CRLF & _
"AT.A.O.1 - Consolidated (production)" & @CRLF & _
"AT.A.X.1 - Consolidated (raw)" & @CRLF & _
"AT.W.O.1 - at.iqos.com (production)" & @CRLF & _
"AT.W.U.1 - at.iqos.com (user-id)" & @CRLF & _
"AT.W.X.1 - at.iqos.com (raw)" & @CRLF & _
"AT.Z.O.1 - iqosinfo.at" & @CRLF & _
"AT.Z.O.2 - iqosjetzt.com" & @CRLF & _
"AT.Z.O.3 - iqosempfehlen.at" & @CRLF & _
"AT.Z.O.4 - iqostesten.at" & @CRLF & _
"AT.Z.O.5 - testeiqos.at" & @CRLF & _
"AT.Z.O.6 - iqosregistrieren.at" & @CRLF & _
"AT.Z.O.7 - iqosprobieren.at"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")