# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<type>.{1})(?<user_access>.{3})(?<group_access>.{3})(?<other_access>.{3}) +(?<oder>[0-9]*) +(?<owner>[a-z]*) +(?<group>[a-z]*) +(?<size>\d*) +(?<month>[a-z]{3}) +(?<day>\d{1,2}) +(?<year>\d{0,4})(?<time>(?<hour>\d{2}):(?<minute>\d{2}))? +(?<filename>(?<basename>.+)\.(?<extension>.*)|(?<no_extension_filename>.*))"
test_str = ("total 80\n"
"drwxr-xr-x 2 root root 4096 Sep 23 15:20 bin\n"
"drwxr-xr-x 3 root root 4096 Sep 3 18:41 boot\n"
"drwxr-xr-x 3 root root 4096 Aug 19 20:48 build\n"
"drwxr-xr-x 14 root root 3900 Sep 23 15:20 dev\n"
"drwxr-xr-x 98 root root 4096 Sep 23 15:20 etc\n"
"drwxr-xr-x 4 root root 4096 Oct 6 2014 home\n"
"drwxr-xr-x 21 root root 4096 Aug 21 19:49 lib\n"
"drwxr-xr-x 2 root root 4096 Jul 8 13:21 lib64\n"
"drwx------ 2 root root 16384 Aug 26 2014 lost+found\n"
"drwxr-xr-x 2 root root 4096 Aug 26 2014 media\n"
"drwxr-xr-x 2 root root 4096 Apr 10 2014 mnt\n"
"drwxr-xr-x 2 root root 4096 Aug 26 2014 opt\n"
"dr-xr-xr-x 133 root root 0 Sep 23 15:20 proc\n"
"drwx------ 4 root root 4096 Sep 23 15:27 root\n"
"drwxr-xr-x 22 root root 760 Sep 23 17:40 run\n"
"drwxr-xr-x 2 root root 12288 Sep 23 15:20 sbin\n"
"drwxr-xr-x 2 root root 4096 Aug 26 2014 srv\n"
"dr-xr-xr-x 13 root root 0 Sep 23 15:20 sys\n"
"drwxrwxrwt 2 root root 4096 Sep 23 17:40 tmp\n"
"drwxr-xr-x 10 root root 4096 Aug 26 2014 usr\n"
"drwxr-xr-x 14 root root 4096 Aug 21 19:52 var\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.