#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?<type>.{1})(?<user_access>.{3})(?<group_access>.{3})(?<other_access>.{3}) +(?<oder>[0-9]*) +(?<owner>[a-z]*) +(?<group>[a-z]*) +(?<size>\d*) +(?<month>[a-z]{3}) +(?<day>\d{1,2}) +(?<year>\d{0,4})(?<time>(?<hour>\d{2}):(?<minute>\d{2}))? +(?<filename>(?<basename>.+)\.(?<extension>.*)|(?<no_extension_filename>.*))"
Local $sString = "total 80" & @CRLF & _
"drwxr-xr-x 2 root root 4096 Sep 23 15:20 bin" & @CRLF & _
"drwxr-xr-x 3 root root 4096 Sep 3 18:41 boot" & @CRLF & _
"drwxr-xr-x 3 root root 4096 Aug 19 20:48 build" & @CRLF & _
"drwxr-xr-x 14 root root 3900 Sep 23 15:20 dev" & @CRLF & _
"drwxr-xr-x 98 root root 4096 Sep 23 15:20 etc" & @CRLF & _
"drwxr-xr-x 4 root root 4096 Oct 6 2014 home" & @CRLF & _
"drwxr-xr-x 21 root root 4096 Aug 21 19:49 lib" & @CRLF & _
"drwxr-xr-x 2 root root 4096 Jul 8 13:21 lib64" & @CRLF & _
"drwx------ 2 root root 16384 Aug 26 2014 lost+found" & @CRLF & _
"drwxr-xr-x 2 root root 4096 Aug 26 2014 media" & @CRLF & _
"drwxr-xr-x 2 root root 4096 Apr 10 2014 mnt" & @CRLF & _
"drwxr-xr-x 2 root root 4096 Aug 26 2014 opt" & @CRLF & _
"dr-xr-xr-x 133 root root 0 Sep 23 15:20 proc" & @CRLF & _
"drwx------ 4 root root 4096 Sep 23 15:27 root" & @CRLF & _
"drwxr-xr-x 22 root root 760 Sep 23 17:40 run" & @CRLF & _
"drwxr-xr-x 2 root root 12288 Sep 23 15:20 sbin" & @CRLF & _
"drwxr-xr-x 2 root root 4096 Aug 26 2014 srv" & @CRLF & _
"dr-xr-xr-x 13 root root 0 Sep 23 15:20 sys" & @CRLF & _
"drwxrwxrwt 2 root root 4096 Sep 23 17:40 tmp" & @CRLF & _
"drwxr-xr-x 10 root root 4096 Aug 26 2014 usr" & @CRLF & _
"drwxr-xr-x 14 root root 4096 Aug 21 19:52 var" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")