// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\[[^\[]*[^\]]*\]").unwrap();
let string = "[products-tab collection=\"frontpage,new,all-1\" title=\"BEST SELLING\" nav=\"true\" style=\"product-loop-swatch\" rows=\"2\" items=\"8\" header=\"style-1\"]
[products-deal product=\"apple-iphone-se,armani-exchange-brown-leather-watch-ax2181\" title=\"DEAL OF THE DAY\"]
[blog blog=\"news\" desc=\"If you are interested in the latest articles in the industry, take a sneak peek at our blog. You’ve got nothing to loose!\" style=\"style-2\"]
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}