import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[[^\\[]*[^\\]]*\\]";
final String string = "[products-tab collection=\"frontpage,new,all-1\" title=\"BEST SELLING\" nav=\"true\" style=\"product-loop-swatch\" rows=\"2\" items=\"8\" header=\"style-1\"]\n\n"
+ "[products-deal product=\"apple-iphone-se,armani-exchange-brown-leather-watch-ax2181\" title=\"DEAL OF THE DAY\"]\n\n"
+ "[blog blog=\"news\" desc=\"If you are interested in the latest articles in the industry, take a sneak peek at our blog. You’ve got nothing to loose!\" style=\"style-2\"]\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}