$re = '/d-16544-p=(\d*)/';
$str = 'd-16544-p=10235';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);