package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`d-16544-p=(\d*)`)
var str = `d-16544-p=10235`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}