const regex = /^\w+([-+.']\w+)*@\w+([-.]\w+)*\.[A-Z0-9]{2,6}([-.][A-Z0-9]{2,6})*$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\w+([-+.\']\\w+)*@\\w+([-.]\\w+)*\\.[A-Z0-9]{2,6}([-.][A-Z0-9]{2,6})*$', 'i')
const str = `thomas-o'leary@upenn.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}