#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)^\w+([-+.']\w+)*@\w+([-.]\w+)*\.[A-Z0-9]{2,6}([-.][A-Z0-9]{2,6})*$"
Local $sString = "thomas-o'leary@upenn.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")