$re = '/(()[0-9]{4})-([0-9]{1,2})(?=,|)/mi';
$str = '2015-12,2016-1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);