using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(()[0-9]{4})-([0-9]{1,2})(?=,|)";
string input = @"2015-12,2016-1";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}