$re = '`^(?P<major>0|[1-9]\d*)\.(?P<minor>0|[1-9]\d*)\.(?P<patch>0|[1-9]\d*)(?:-(?P<prerelease>(?P<stage>(?:alpha|beta|rc))(?:\.(?P<feature>(?:(?P<pic>[0-9a-zA-Z-]*)\.)?[0-9a-zA-Z-]*))?))?(?:\+(?P<buildmetadata>[0-9a-zA-Z-]+(?:\.[0-9a-zA-Z-]+)*))?$`m';
$str = '0.2.19-beta.sppe-123+noescape
0.2.19-beta.fix-panic
0.2.18-alpha.zhihua-zeng.performance-improvement-test
0.2.18-rc
0.2.17
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);