#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?P<major>0|[1-9]\d*)\.(?P<minor>0|[1-9]\d*)\.(?P<patch>0|[1-9]\d*)(?:-(?P<prerelease>(?P<stage>(?:alpha|beta|rc))(?:\.(?P<feature>(?:(?P<pic>[0-9a-zA-Z-]*)\.)?[0-9a-zA-Z-]*))?))?(?:\+(?P<buildmetadata>[0-9a-zA-Z-]+(?:\.[0-9a-zA-Z-]+)*))?$"
Local $sString = "0.2.19-beta.sppe-123+noescape" & @CRLF & _
"0.2.19-beta.fix-panic" & @CRLF & _
"0.2.18-alpha.zhihua-zeng.performance-improvement-test" & @CRLF & _
"0.2.18-rc" & @CRLF & _
"0.2.17" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")