re = /[|\s]+|[=\s]+/
str = ' , this, is a ,,, test string , , to find regex,,in js. , '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end