$re = '/[|\s]+|[=\s]+/';
$str = ' , this, is a ,,, test string , , to find regex,,in js. , ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);