import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " (?(DEFINE)\n"
+ " (?<unreserved> [-._~[:alnum:]] )\n"
+ " (?<sub_delims> [!$&'()*+,;=] )\n"
+ " (?<pct_encoded> %[[:xdigit:]][[:xdigit:]] )\n"
+ " (?<pchar> @|(?&unreserved)|(?&pct_encoded)|(?&sub_delims) )\n"
+ " (?<seg_nz_nc> (?&pchar)+ )\n"
+ " (?<seg_nz> (?::|(?&pchar))+ )\n"
+ " (?<seg> (?::|(?&pchar))* )\n"
+ " (?<rootless> (?&seg_nz)(?:\\/(?&seg))* )\n"
+ " (?<noscheme> (?&seg_nz_nc)(?:\\/(?&seg)*) )\n"
+ " (?<absolute> \\/(?:(?&seg_nz)(?:\\/(?&seg))*)? )\n"
+ " (?<abempty> (?:\\/(?&seg))* )\n"
+ " )\n"
+ " ^(?:(?&rootless)|(?&noscheme)|(?&absolute)|(?&abempty))$\n"
+ " ";
final String string = "/bla/asd/f.fasdf";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}