using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" (?(DEFINE)
(?<unreserved> [-._~[:alnum:]] )
(?<sub_delims> [!$&'()*+,;=] )
(?<pct_encoded> %[[:xdigit:]][[:xdigit:]] )
(?<pchar> @|(?&unreserved)|(?&pct_encoded)|(?&sub_delims) )
(?<seg_nz_nc> (?&pchar)+ )
(?<seg_nz> (?::|(?&pchar))+ )
(?<seg> (?::|(?&pchar))* )
(?<rootless> (?&seg_nz)(?:\/(?&seg))* )
(?<noscheme> (?&seg_nz_nc)(?:\/(?&seg)*) )
(?<absolute> \/(?:(?&seg_nz)(?:\/(?&seg))*)? )
(?<abempty> (?:\/(?&seg))* )
)
^(?:(?&rootless)|(?&noscheme)|(?&absolute)|(?&abempty))$
";
string input = @"/bla/asd/f.fasdf";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}