$re = '/^ *(\d{4}-?)?\d{2}-?\d{3}-?\d{4} *$/';
$str = '1234-99-123-4567';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);