package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^ *(\d{4}-?)?\d{2}-?\d{3}-?\d{4} *$`)
var str = `1234-99-123-4567`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}