// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?<latitude>[-]?[0-8]?[0-9]\.\d+|90\.0+?)(?<delimeter>.)(?<longitude>[-]?1[0-7][0-9]|[0-9]?[0-9]\.\d+|180\.0+?)").unwrap();
let string = "20.12321;80.0";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}