$re = '/([^-]*)/';
$str = 'en_us-fr_fr';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;