#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([^-]*)"
Local $sString = "en_us-fr_fr"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)