$re = '/final states\s*=\s*{([^}]*)}/m';
$str = 'final states = {q2}
final states = {q2, q3,q4}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);