package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)final states\s*=\s*{([^}]*)}`)
var str = `final states = {q2}
final states = {q2, q3,q4}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}