$re = '/(^[1-4]{1}(\.\d{0,1})?$)|(^5{1}$)/';
$str = '1.3';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);