package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(^[1-4]{1}(\.\d{0,1})?$)|(^5{1}$)`)
var str = `1.3`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}