$re = '/(?x)
#\w{3}
#\w{2}
#\w{2,4}
#\w{2,4}?
/m';
$str = 'hello how are you?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);