package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?x)
#\w{3}
#\w{2}
#\w{2,4}
#\w{2,4}?
`)
var str = `hello how are you?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}