#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "CR.DITO\s*TUSD\s*KW\s*\-\s*APCEI\s*\-\s*N\s*CONS[A-Z.]*\s*\d{2}\/\d{4}\s*(?<VlrDNUtilCred>[0-9.-]+\,?\d*)"
Local $sString = "Junho 2019" & @CRLF & _
" " & @CRLF & _
"0606 DEBITO TUSD KW - APCEI 04/2019 65,16 0,00 0 0,00 0,00 0,00 0,00" & @CRLF & _
"0606 DEB. DA TUSD KW-APCEI- N CONS. 04/2019 1,73 0,00 0 0,00 0,00 0,00 0,00" & @CRLF & _
"0606 CREDITO DA TUSD KW - APCEI 06/2019 -22.034,82 0,00 0 0,00 0,00 0,00 0,00" & @CRLF & _
"0606 CREDITO TUSD KW-APCEI -N CONS. 06/2019 -238,64 0,00 0 0,00 0,00 0,00 0,00" & @CRLF & _
" " & @CRLF & _
"Janeiro 2020" & @CRLF & _
" " & @CRLF & _
"0606 DEBITO TUSD KW - APCEI 11/2019 50,85 0,00 0 0,00 0,00 0,00 0,00" & @CRLF & _
"0606 DEB. DA TUSD KW-APCEI- N CONS. 11/2019 0,92 0,00 0 0,00 0,00 0,00 0,00" & @CRLF & _
"0606 CREDITO DA TUSD KW - APCEI 01/2020 -22.514,07 0,00 0 0,00 0,00 0,00 0,00" & @CRLF & _
"0606 CREDITO TUSD KW-APCEI -N CONS. 01/2020 -404,71 0,00 0 0,00 0,00 0,00 0,00" & @CRLF & _
" " & @CRLF & _
"Abril 2020" & @CRLF & _
" " & @CRLF & _
"0606 DÉBITO TUSD KW-APCEI 02/2020 102,86 0,00 0 0,00 0,00 0,00 0,00" & @CRLF & _
"0606 DÉBITO TUSD KW-APCEI - N CONSUMIDA 02/2020 0,92 0,00 0 0,00 0,00 0,00 0,00" & @CRLF & _
"0606 CREDITO TUSD KW-APCEI 04/2020 -23.968,26 0,00 0 0,00 0,00 0,00 0,00" & @CRLF & _
"0606 CREDITO TUSD KW-APCEI - N CONSUMIDA 02/2020 -0,92 0,00 0 0,00 0,00 0,00 0,00" & @CRLF & _
"0601 Substituição Tributária - Crédito 378.862,670 0,248265 94.058,22 94.058,22 32 30.098,63 0,00 0,00 0,00" & @CRLF & _
"0906 Substituição Tributária - Débito 378.862,670 0,248265 -63.959,60 0,00 0 0,00 0,00 0,00 0,00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")