use strict;
my $str = '# H1
## H2
### H3
# A First Level Header
## Second Level Header
Now is the time for all good men to come to the aid of their country. This is just a regular paragraph.
The quick brown fox jumped over the lazy dog\'s back.
*The* quick brown fox jumped over the lazy dog\'s back.
**The** quick brown fox jumped over the lazy dog\'s back.
`The` quick brown fox jumped over the lazy dog\'s back.
[The]() quick brown fox jumped over the lazy dog\'s back.
### Header 3
> This is a blockquote.
>
> This is the second paragraph in the blockquote.
>
> ## This is an H2 in a blockquote';
my $regex = qr/^(?:([*_`]|\*\*|\[){0,1}[a-z]+)(.*)/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}