package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\d{3}\-\d{2}\-\d{4}$`)
var str = `122-67-9090`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}