$re = '/^\d{3}\-\d{2}\-\d{4}$/';
$str = '122-67-9090';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);